Cách cài đặt Driver cho mạch Arduino Compatible (CP210x / CH34x)

From MakerLab Wiki
Jump to navigation Jump to search

Tải và Cài đặt Driver

Các mạch Arduino Compatible thường sẽ sử dụng hai loại IC nạp chương trình và giao tiếp UART chính là CP210x (CP2102, CP2104,...) và CH34x (CH340, CH341,...), các bạn có thể tải và cài đặt Driver tại đây theo Hệ Điều Hành (HĐH) (Windows, MAC, Linux) mà bạn đang sử dụng:

Sau khi quá trình cài đặt Driver hoàn tất, các bạn kết nối mạch Arduino Compatible vào máy tính, để kiểm tra xem mạch đã nhận chưa, bạn nhấn chuột phải vào “Computer” (My Computer / This PC) -> “Properties" -> “Device Manager” -> "Ports (COM&LPT)", nếu thấy đã nhận thiết bị và đánh số cổng COM như như hình là hoàn tất:

Cài đặt Driver CP2102 thành công nhận cổng COM3
Cài đặt Driver CP2102 thành công nhận cổng COM3
Cài đặt Driver CH340 thành công nhận cổng COM4
Cài đặt Driver CH340 thành công nhận cổng COM4

Nạp chương trình mẫu vào mạch Arduino Compatible để kiểm tra hoạt động

Bước 1: Mở chương trình Arduino
Sau khi đã cài đặt Driver tương thích cho mạch Arduino Compatible, các bạn khởi động chương trình Arduino bằng cách nhấn vào icon Arduino trên Desktop hoặc trong thư mục cài đặt:
KS0313-6.png

Bước 2: Khởi tạo chương trình
Sau khi khởi động chương trình Arduino, bạn có thể khởi tạo 1 chương trình mới hoặc mở 1 chương trình mẫu sẵn có (Example) của Arduino.

Nếu bạn muốn khởi tạo chương trình mới chọn “File”->“New” để khởi tạo:
KS0313-7.1.png

Để mở 1 chương trình mẫu sẵn có, ví dụ ở đây căn bản nhất là chương trình "Blink" để chớp tắt đèn led tại chân số 13 của Arduino ta chọn File->Example->Basics->Blink:
KS0313-8.1.png

KS0313-8.2.png

Bước 3: Chọn loại board Arduino mà bạn sử dụng

Mạch Arduino Compatible của bạn ví dụ là Vietduino Uno (Arduino Uno Compatible) thì các bạn vào Tools→Board và chọn board là Arduino Uno:
KS0313-10.png

Sau đó chọn cổng COM theo đúng số cổng COM trong “Device Manager” -> "Ports (COM&LPT)" đã hướng dẫn ở trên trong phần "Tools"→"Port":
KS0313-11.png

Bước 4: Nạp (Upload) chương trình vào mạch Arduino:
Để nạp (Upload) chương trình vào Arduino hoặc muốn kiểm tra lỗi của chương trình trước khi nạp bạn sử dụng thanh công cụ trên phần mềm như hình:
KS0313-12.png
A- Biên dịch thử chương trình để kiểm tra lỗi.
B- Nạp (Upload) chương trình vào Arduino.
C- Mở 1 chương trình mới.
D- Mở 1 chương trình sẵn có.
E- Lưu chương trình.
F- Sử dụng để truyền nhận dữ liệu từ máy tính sang Arduino bằng giao tiếp COM (UART).

Sau khi nhấn nút Upload (B) để nạp chương trình mẫu "Blink" vào mạch Arduino Compatible ta sẽ thấy Led tại chân 13 chớp tắt tuần tự với thời gian 1 giây.