Cách cài đặt Driver cho mạch Arduino

From MakerLab Wiki
Jump to navigation Jump to search

Cài đặt Driver cho mạch Arduino

Có rất nhiều phiên bản Hệ điều hành (Windows, Linux, MacOS,...) có thể chạy chương trình Arduino tuy nhiên hướng dẫn được thực hiện dựa trên phiên bản hệ điều hành phổ dụng hiện nay là Windows 7.

Sau khi cài đặt phần mềm Arduino thì trong thư mục chứa chương trình Arduino trên máy tính (thường nằm trong thư mục Program Files) sẽ có thư mục "Driver" chứa tất cả Driver của các loại bo mạch Arduino, để có thể cài đặt Driver cho mạch Arduino khi mới sử dụng có thể tham khảo các bước sau:

- Kết nối mạch Arduino với máy tính qua cổng USB.
- Khi mạch Arduino đã kết nối với máy tính và sáng đèn nguồn, bạn nhắn chuột phải vào “Computer” (My Computer / This PC) -> “Properties" -> “Device manager” -> “Other Devices”, bạn sẽ thấy một thiết bị hiển thị là “Unknown device”, nếu không có các thiết bị khác cùng kết nối vào máy tính thì đây chính là mạch Arduino khi chưa cài đặt Driver:
Driver 1.png

- Nhấn chuột phải vào “Unknown device” và chọn "Update Driver Software":
Driver 2.png

- Chọn “Browse my computer for driver software”:
Driver 3.png
- Tiếp theo bạn chọn đường dẫn là thư mục “Drivers” trong thư mục cài đặt Arudino trên máy tính (thường nằm trong thư mục Program Files):
Driver 4.png

- Tiếp theo bạn nhấn "Next" để cài đăt, nếu có hiện ra bản cảnh báo thì chọn "Install this driver software anyway" để tiếp tục cài đặt:
Driver 5.png
- Sau khi quá trình cài đặt hoàn tất, Windows sẽ nhận ra mạch Arduino của bạn, nhấn "Close" để kết thúc việc cài đặt:
Driver 6.png
- Vào lại “Device manager”, bạn sẽ thấy hiển thị mạch Arduino đã được cài đặt Driver với cổng COM kết nối máy tính hoàn tất như hình:
Driver 7.png

Nạp chương trình mẫu vào Arduino để kiểm tra hoạt động

Bước 1: Mở chương trình Arduino
Sau khi đã cài đặt chương trình Arduino bạn có thể khởi động chương trình Arduino bằng cách nhấn vào icon Arduino trên Desktop hoặc trong thư mục cài đặt:
KS0313-6.png

Bước 2: Khởi tạo chương trình
Sau khi khởi động chương trình Arduino, bạn có thể khởi tạo 1 chương trình mới hoặc mở 1 chương trình mẫu sẵn có (Example) của Arduino.

Nếu bạn muốn khởi tạo chương trình mới chọn “File”->“New” để khởi tạo:
KS0313-7.1.png

Để mở 1 chương trình mẫu sẵn có, ví dụ ở đây căn bản nhất là chương trình "Blink" để chớp tắt đèn led tại chân số 13 của Arduino ta chọn File->Example->Basics->Blink:
KS0313-8.1.png

KS0313-8.2.png

Bước 3: Chọn loại board Arduino mà bạn sử dụng

Mạch Arduino sử dụng IC chuyển USB to COM (UART) trên mạch để nạp chương trình và giao tiếp với máy tính, để có thể nạp chương trình vào mạch Arduino bạn cần chọn đúng cổng COM mà Arduino đang sử dụng trên máy tính, để kiểm tra Arduino đang sử dụng cổng COM nào bạn nhấn chuột phải vào “Computer” (My Computer / This PC) -> “Properties" -> “Device manager” -> Ports (COM & LPT):
Driver 7.png

Sau khi đã biết cổng COM mạch Arduino sử dụng để kết nối với máy tính, bạn thiết lập loại Arduino đang sử dụng bằng cách vào phần mềm Arduino và chọn Tools→Board, ví dụ ở đây là Arduino Uno:
KS0313-10.png

Sau đó chọn cổng COM Arduino đang sử dụng trong Tools→Serial Port trùng với cổng COM trong Device manager:
KS0313-11.png

Bước 4: Nạp (Upload) chương trình vào mạch Arduino:
Để nạp (Upload) chương trình vào Arduino hoặc muốn kiểm tra lỗi của chương trình trước khi nạp bạn sử dụng thanh công cụ trên phần mềm như hình:
KS0313-12.png
A- Biên dịch thử chương trình để kiểm tra lỗi.
B- Nạp (Upload) chương trình vào Arduino.
C- Mở 1 chương trình mới.
D- Mở 1 chương trình sẵn có.
E- Lưu chương trình.
F- Sử dụng để truyền nhận dữ liệu từ máy tính sang Arduino bằng giao tiếp COM (UART).

Sau khi nhấn nút Upload (B) để nạp chương trình mẫu "Blink" vào Arduino ta sẽ thấy Led tại chân 13 của Arduino chớp tắt tuần tự với thời gian 1 giây.